Eclipse StartOnFirstThread Error (and fix!)

This appears to be an issue with the JVM under Leopard (Mac OS X 10.5), but I started getting the following error within Eclipse when using the ResourceBundleEditor plugin:

StartOnFirstThread Error Message

It also apparently happens with other plugins/apps and is an issue with the AWT kit in the new JVM. After pouring through all of my Eclipse config files and determining that I definitely was NOT specifying StartOnFirstThread anywhere, I found this fix:

Within the Eclipse application bundle, in the file Contents/MacOS/eclipse.ini, add this line:


Save the file, and restart Eclipse. Problem solved.







4 responses to “Eclipse StartOnFirstThread Error (and fix!)”

  1. Adam Fisk Avatar

    Thanks a million – worked like a charm. I just had one of those days almost completely consumed with Eclipse/webapp/maven etc configuration issues, so it was very helpful to knock this particularly annoying one off at the end. Much appreciated.


  2. Devon Avatar


    I’m very glad I could help!


  3. Greg Johnson Avatar
    Greg Johnson

    Alas, this is a big pain for me with my RCP app which only works when run from within Eclipse, but not once exported. Just in case someone else comes looking, this doesn’t help me. I’m using the SWT_AWT bridge, and (makes sense really) headless AWT doesn’t make anything better. Back to google…

    But thanks – you got me excited for 18seconds!

  4. Devon Avatar


    I’m sorry to disappoint! If you find a solution, it would be great if you could share it here as well for other people like yourself.

    Good luck!


Leave a Reply

Your email address will not be published. Required fields are marked *

PHP Code Snippets Powered By :